Remove Slider From Blog posts page

Home Forums SKT Black/White Theme Support Remove Slider From Blog posts page

This topic contains 10 replies, has 2 voices, and was last updated by  Tiffany Clements 1 year, 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #99360

    Tiffany Clements
    Participant
    • Topics: 12
    • Replies: 28
    • Total: 40
    Member since: June 1, 2015

    Hi!

    When setting a static page for the blog posts I notice that the default slider from the homepage appears above the posts. However, I do not need the slider to appear in both places only on the homepage. What custom CSS can I use to remove it from the blog page? Celebrity Scope I tried this code to see if it can be achieved by page Id, but no such luck.

    .page-id-2477 .slider-main {
       display: none;
    }
    #99367

    Forum Moderator
    Participant
    • Topics: 0
    • Replies: 21457
    • Total: 21457
    Member since: August 16, 2013

    Hi,

    Kindly go to Appearance >> Theme Options >> Basic Settings >> Custom CSS Box:

    Add this code there:

    .blog .slider-main {
        display: none;
    }

    Regards,
    Chris

    #99370

    Tiffany Clements
    Participant
    • Topics: 12
    • Replies: 28
    • Total: 40
    Member since: June 1, 2015

    Hi, Chris!

    That code didn’t do the trick. It actually removes the default slider from both the homepage and blog posts page.

    #99402

    Forum Moderator
    Participant
    • Topics: 0
    • Replies: 21457
    • Total: 21457
    Member since: August 16, 2013

    Hi,

    Kindly go to Appearance >> Theme Options >> Homepaeg Slider >> Inner Page Slider >> and change there

    Have a look at:
    http://sktthemesdemo.net/documentation/skt-white-doc/assets/img/slider-settings.jpg

    Regards,
    Chris

    #99407

    Tiffany Clements
    Participant
    • Topics: 12
    • Replies: 28
    • Total: 40
    Member since: June 1, 2015

    I’m confused. What am I supposed to be changing that will keep the slider on the homepage, but remove it from blog posts page? I have the inner page slider already set to hide and I tried the show option and no change. What am I supposed to be doing here? The CSS code you provided removed it from both pages completely. How can it be edited to target the blog posts page only?

    #99435

    Forum Moderator
    Participant
    • Topics: 0
    • Replies: 21457
    • Total: 21457
    Member since: August 16, 2013

    Hi,

    Kindly send us your URL of the site and WordPress admin details (Username & Password) via sktthemes.net/contact Please mention this forum URL while replying so that we understand what needs to be done.

    Regards,
    Chris

    #99486

    Forum Moderator
    Participant
    • Topics: 0
    • Replies: 21457
    • Total: 21457
    Member since: August 16, 2013

    Hi,

    Issue resolved form our end. Kindly check and confirm.

    Regards,
    Chris

    #99489

    Tiffany Clements
    Participant
    • Topics: 12
    • Replies: 28
    • Total: 40
    Member since: June 1, 2015

    Issue not resolved. Slider still exists on posts page. Please follow this link

    #99490

    Forum Moderator
    Participant
    • Topics: 0
    • Replies: 21457
    • Total: 21457
    Member since: August 16, 2013

    Hi,

    Kindly delete cache and do a forced refresh as we are not getting any kind of error in console.

    To do a forced refresh kindly follow below instructions:

    Windows/Linux:
    1. Hold down Ctrl and click the Reload button.
    2. Or, Hold down Ctrl and press F5.

    Mac:
    1. Hold Shift and click the Reload button.
    2. Or, hold down Cmd and Shift key and then press R.

    Regards,
    Chris

    #99638

    Tiffany Clements
    Participant
    • Topics: 12
    • Replies: 28
    • Total: 40
    Member since: June 1, 2015

    I think you don’t understand what I am saying. I actually wasn’t referring to any errors. What I am referring to is your slider shows up by default on the posts page when in the reading settings if the blog posts page it is set as a static page. I need to know how to remove the slider from the static posts page. The static page for the glo psost needs to be set to this linkBlog I have attached screenshots. Reader Settings/blog posts static page

    When the static page is selected this is how the slider appears. As I mentioned before I do not want it to appear on the posts/blog page at all. The only way it does not appear is if a static page is not selected and that shouldn’t be. you guys forced me to pay for extra support to correct this so surely there is something you can do. I need to be able to set static pages for both the homepage and posts pages.
    Static posts page that includes slider

    Please log into my website to see for yourself.

    #100014

    Tiffany Clements
    Participant
    • Topics: 12
    • Replies: 28
    • Total: 40
    Member since: June 1, 2015

    When will the default slider be moved from posts page? I am still awaiting assistance in resolving this issue. It appears that the problem I’m having with properly setting the static posts page and homepage in this thread, and here, is because your theme was not designed with a front-page.php file or a the necessary template for the blog page to become a static posts page. So since you referenced my child theme, it adapts templates from the parent file. So, if these missing templates are added to the parent theme they would work with the child theme by default because I would have no reason to edit them unless they are poorly designed and problem causing. So when will I receive help? I started these threads a week ago and I’m still waiting.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.