featured image not showing on page and cropped to show in browser height only

Home Forums SKT Full Width Forum featured image not showing on page and cropped to show in browser height only

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #44250
    MP EK
    Member
    • Topics: 40
    • Replies: 149
    • Total: 189
    Member since: October 21, 2015

    Hello,

    we added a new page to the site and took an image to be featured image, but suddenly behavior changed:

    1. Image doesn’t show in content area
    2. Image doesn’t show as oversized background image

    In fact, it shows in browser height only (somehow scaled down automatically) and this makes the image not to be seen, because it is overlayed by content area and the rest of the background apperas in ugly black.

    Make the vrowser window smaller, then you can see the image behind content.

    Could the site be setup that when a pic is too small, that the already defined background color (not black) is being used to show, let’s say background color for an featured-background-image.

    The same happens to posts as well.

    The image is 2035 × 3072 px. It should fit background easily, as it’s not too small to be a full screen background image, but behaves like it is.

    The site is configured to use featured image as background image!

    WordPress is 4.5.3.

    What could cause this behavior that you know of?

    #44312
    SKT Themes
    Keymaster
    • Topics: 8
    • Replies: 6705
    • Total: 6713
    Member since: June 12, 2013

    Background image size should be 1600px wide and 1200px in height instead of the one you have now which is why it doesn’t show up.

    Regards,
    Shri

    #44327
    MP EK
    Member
    • Topics: 40
    • Replies: 149
    • Total: 189
    Member since: October 21, 2015

    Well, I have recognized that this is not necessary. The featured image gets blown up until it fills in as background behind posts and pages and suddenly this does not work. Do you know what I mean and why this does not work now?

    #44334
    MP EK
    Member
    • Topics: 40
    • Replies: 149
    • Total: 189
    Member since: October 21, 2015

    I understand, but it’s ugly when you insert a vertical image – as a featured image – into a post, the sides are then black, can black be change to something else as a standard setting?

    #44339
    MP EK
    Member
    • Topics: 40
    • Replies: 149
    • Total: 189
    Member since: October 21, 2015

    or is it possible to show vertical image in full browser width?
    This is a post with vertical image. Password is test.
    It would be nice if this picture could stay behind the content area and perhaps scroll with if content are is being scrolled

    #44343
    MP EK
    Member
    • Topics: 40
    • Replies: 149
    • Total: 189
    Member since: October 21, 2015

    I just recognized that only the text in this post above is protected by password, but not the image! Could you please check the security settings in this theme?

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.